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Our Summer 2020 Release includes:

• The new Help Request System

• Integrations for firearms and accounting

• Expanded mobile device support and apps

• New Point of Sale features



The New Help Request Portal



The new Help menu category: “Support”

• A new Support category on the Help menu 

provides access to Chat Support and the 

new Help Request Portal. 

• Submit a Help Request replaces the “Open 

a New Case” menu option which opened in a 

browser window. This new Help Request 

Portal is integrated into Paladin.

• View Active Requests replaces the “My 

Cases” page on the Help Portal website. 

This feature also opens in Paladin.



Submit a Help Request

• Answer the store-down emergency 

question and then fill out the Help 

Request form.

• Select a Category and Subject that 

best fit your issue. Accurate 

selections will expedite your request.

• Enter a detailed Description and a 

contact Phone and Email.

• Attachments can be added after you 

submit the request using Help > 

Support > View Active Requests



Help Request Confirmation Email 

• After you submit a new Help 

Request, you will receive a Help 

Request ID. 

• This ID will also be sent to the 

contact email address you 

entered. 

Mary Smith



The new Help Request Portal makes Paladin Support even better

You'll experience even more efficient and responsive 

support due to these enhancements:

• Fully-integrated into Paladin and automatically collects 

vital data about your unique system when help is 

request.

• Categories quickly direct your request to the most 

knowledgeable support team.

• Our products and customer service are 

continually optimized based on the data we collect.



New integrations



FastBound integration

• Simplify the complicated process of 

selling firearms with the FastBound

integration.

• Guaranteed compliance for firearm 

acquisition and disposition (A&D), 

an electronic 4473, and an 

electronic bound book with 

FastBound’s FFL software.

• Receive and sell firearms in Paladin 

while simultaneously updating 

FastBound A&D and your electronic 

bound book.



QuickBooks Online integration

• QuickBooks integration now 

supports the online version

• Sync the day’s general ledger 

activity summary to your 

QuickBooks Online general ledger 

each night.

• Automatically create an accounts 

payable invoice from a purchase 

order, minutes after you receive new 

product and close a purchase order 

in Paladin.



Expanded mobile device supportand apps



Touch Dynamic Quest III Tablet

E

• Take the power of Paladin with you anywhere on 

your business network with this agile 10-inch 

Windows tablet

• Use all Paladin features including inventory 

management, EDI, purchase orders, pricing 

plans/sale lists, quotes and customer sales

• Barcode scanner and EMV enabled. Runs Office 

365 and other Windows programs

• EMV Level 3 certified. Compatible with WorldPay 

and DataCap. Supports signature capture.

• Connect your store’s database, printers and other 

peripherals via WIFI

EMV chip slot

Barcode scannerCard swipe

Fingerprint reader



Samsung Galaxy Tab Active 2

Card reader

• Android device optimized for 

Mobile2Checkout and many other partner 

applications

• Sell anytime and anywhere with an internet 

connection (cellular or WIFI)

• Collect signatures and process payments

• Optional uDynamo card reader available 

with the bundle

• Compact 8-inch form factor makes device 

easy to hold and use

• Rugged tablet with water-resistant S Pen 

and screen



Ingenico Lane 7000/8000 payment terminals

• User-friendly, multimedia touchscreen 

payment processors with built-in signature 

capture PIN pad.

• Accept all major payment types, including 

touchless, and features a stylus for quick 

signature capture.



Mobile2Checkout app

• Works on most newer Android devices

• Sell anytime, anywhere

• Accept multiple tender types, including cash, 

check, debit/credit cards, gift cards, and 

charge on account

• Store orders and process returns.

• NEW! Recall stored quotes and checkout on 

your mobile device

• NEW! Respect pricing plans and trade 

discounts.

• Requires version 1.1.1 or higher



New EDI Support



Smith Drug EDI support

EDI support has been added 

for the Smith Drug Company



New Point of Sale features



Show MBF, MSF and Ton prices on quotes/invoices

• A new inventory setting (checkbox) lets you show 

prices in thousand board feet (MBF), thousand 

square feet (MSF) or ton on invoices and quotes. 

• To turn on, select the MBF, MSF or TON checkbox. 

(Cost Per: must be set to unit first.)



Square Footage Calculator

• Calculate square foot quantities 

for an invoice item based on 

dimensions (width/length) and # 

pieces that you enter.

• Quantities are recorded in a note.

• Right-click the item to access the 

calculator from the Quick Access 

menu or press Ctrl + S



Numbered quotes

• Incremental quote numbers can be 

automatically added for easy 

reference.

• Find quotes quickly by number 

when your customer is ready to 

buy.

• Turn on quote numbers in File > 

Setup > Invoice (Store) tab, 

select Enable Quote Numbers.



Apply freight cost to EDI invoice items

• Apply a freight cost to an EDI 

invoice and then distribute the cost 

across its received items in the EDI 

Reporting window. 

• Freight column icons identify 

invoices that are eligible for a freight 

cost (   ) and invoices where freight 

has been applied (   ).

This feature is already available for manual receiving.



Apply freight cost to EDI invoice items

• Freight costs can be distributed by item cost 

or item weight.

• Tip It’s a best practice to apply freight cost 

soon after the EDI invoice is processed and 

before received items are sold. 



Customized email invoice messages

• Add custom message, your 

store hours, a note about 

upcoming promotions or other 

custom text when your client 

opts for an email invoice.

• Enter your text in File > Setup

> Forms tab > Email

Message box.



Create a new purchase order for backordered items

• Create a new purchase 

order form a PO with 

backordered items.

• The existing PO will be 

closed and a new PO 

created for the 

backordered items.

• To access this feature, 

use Find PO to locate 

the purchase order and 

then click Revise PO.



Create a new purchase order for backordered items

• The new PO name is 

prefixed with “Revise 

PO” and contains the 

prior PO’s #.

• It appears automatically 

in the Recall 

Transaction window.



Add precision to PO quantity and price

• Add decimal places to line item 

quantities and prices on 

purchase orders.

• To add more precise values, 

right-click the line item and 

select Add Precision from the 

Quick Access menu.



Schedule reports for weekday only

Schedule reports to run on 

weekdays only with a new

Daily – Exclude Weekends

option.



Excel version of the Credit Card Deposit Report

• View and analyze credit card 

transactions easily with a new 

Excel option.

• The Excel workbook includes 

separate worksheets (tabs) 

for each employee or 

terminal, depending on the 

option you choose.



“Customer Friendly” Transaction Report

• View a Customer Friendly version of the Excel Transaction Report that 

omits department, cost and margin data. 

• If you want the original view, select Accounting Department.



Automatically exclude special orders from rewards

• Prevent special orders from earning 

rewards.

• Available for Ace Rewards, Rich 

Rewards or Repeat Rewards.

• Create a new no-rewards class (method 

varies by rewards program), and set

Default Class for Special Order Items 

(Company tab) to the class ID.

REWARDS



EMV stores: Swipe credit cards to put them on-file in Paladin 

• For EMV-enabled stores, a new 

checkbox lets you optionally swipe a 

credit card to put it on-file in Paladin. 

• This feature is already available for 

stores that are not setup for EMV.

• To swipe the card instead of manually-

enter the card number, when you start 

the on-file process, in the Device 

Manager window, clear (deselect) the 

Manual Entry checkbox that is 

selected by default.



Product image viewer in Advanced Lookup

• In the Advanced Lookup 

window, a magnifying glass will 

open a product image (when 

available).

• Product images are added 

during EDI processing and will 

increase in number over time.

• This feature is available for 

True Value and Ace Hardware.



Ace Hardware features



Ace Hotsheetsprocess automatically overnight

• Paladin EDI will automatically process Ace Hotsheets

and maintenance updates overnight (4 am local time).

• Price increases are delayed to ensure your bin tag 

prices aren’t lower than the inventory prices. 

• Ace EDI invoices are still processed manually. 

• A manual step (EDI [F9] > Download Files) is still 

required to process EDI invoices and delayed prices 

updates.

• However, your EDI processing wait time will be short 

because the bulk of the processing (Hotsheets and 

maintenance) was done overnight.

Overnight Hotsheet 

processing

ACE



Revenue Report update for 

Ace Instant Savings and Dynamic Promotions 

• After June 1, 2020, Ace Instant 

Savings and Dynamic Promotions 

will appear under two new 

department categories:

• Ace Inst Savings (Dept ID 10201)

• Ace Dynamic Prom (Dept ID 10202)

• No changes to tax or accounting 

calculations in Paladin.

• Changes were made to prevent 

revenue totals from appearing 

greater than taxable totals when 

promotions are taxed.



Support for Big Green Egg online/pick up in store orders

• Big Green Egg items sold on 

Acehardware.com now 

require Ace Hardware SKUs.

• To ensure that your customers 

can purchase Big Green Egg 

products online from your store, 

run the BGE SKU conversion too.

• In Paladin, go to Maintain > 

Utilities > Ace Utilities > Ace 

BGE SKU Conversion



True Value Hardware features



New True Value EDI file support

Paladin added support for these True Value EDI files:

• Fineline Updates – Updates True Value finelines (weekly).

• Long Descriptions – AddsTrue Value long product descriptions 

into the Description 3 field in Paladin (General tab > Item

Information pane) for new and updated items (weekly).

• Images – Imports product images into Paladin for new and 

updated items. When available, product images can be viewed 

in the Advanced Lookup window (weekly).

• Drop Ship – Process drop ship invoices (daily). 

• RDC Balances – Update remote stock check data (daily).

• Vendor Locations – Update vendor locations (weekly). 

• Vendor Direct Ship Terms – Process vendor shipment data 

(daily M-F).

EDI



Support for Weekly Inventory/Pricing uploads

• Paladin added support for daily (end-of-day) pricing 

and inventory uploads to True Value for both non-

True Value and True Value products. 

• To enable this upload, go to File > Setup > 

Rewards tab > True Value Upload pane, and 

select Daily Inventory/Pricing (Spec 98)

Nightly

upload



True Value EDI automatically creates pricing plans

• During EDI processing, when 

you select True Value 

promotions. Paladin will 

automatically create the pricing 

plans.

• We’ll also declutter your sales 

list by deleting old sales .



Pharmacy features



Enhanced Prescription Drug Monitoring Program (ePDMP)

• Record who picks up a prescription 

further protecting stores and customers 

from liability and compliance issues.

• This enhancement requires the user to 

provide the name and ID of the person 

picking up a controlled substance 

prescription.

• This feature is currently available for 

SpeedScript.

• Required in some states, and others 

are likely to follow.



For additional details, view the

Summer 2020 Release Guide

portal.paladinpos.com/new-features/summer-2020

E

https://portal.paladinpos.com/release-notes/new-features/summer-2020-release-guide




Next Webinar:

Streamline Firearms Sales with FastBound

August 18 @ 9am PT

Register: portal.paladinpos.com/webinars

https://portal.paladinpos.com/webinars/


Stay relevant in retail:

paladinpointofsale.com/retailscience

Self help at:

portal.paladinpos.com 

Expand your Paladin Knowledge:

Webinars available at:

portal.paladinpos.com/webinars

Follow us for Paladin news and updates:

Check out our Summer 2020 Release Guide on 

the Help Portal.


